≡ Menu

WordPress 2.5 upgrade

I have upgraded my blog to WordPress 2.5.

Please, let me know if you see anything that isn’t right.

It’s the first time I have done an upgrade without using Fantastico.

My hands are still shaking.

I was a nervous wreck during the upgrade fearing the worst.

I have spent a month going back and forth as to whether I should wait until fantastico has the newest version of WordPress available or do the upgrade by myself.

Yesterday, I had decided to wait. That was yesterday.

Twenty minutes ago, I started the process of backing up my blog, downloaded WordPress 2.5, opened up my ftp, deleted files (I felt nauseous doing that) and uploading the new files. There were a few more steps but I am not here to write instructions on how to do an upgrade.

Once the new files uploaded, I went to my blog to finish the upgrade and held my breath waiting the one second it took to see if my blog was still there.

It was. :)

Some of you may have found the blog down during upgrading which is normal.

The upgrade wasn’t hard to do and I am happy I conquered my fear!

Why put myself through all that stress?

Fantastico is notorious for being two weeks to over a month behind WordPress upgrade releases. With this release that wasn’t a big deal. However, in the past when there were security updates I wasn’t happy to wait. I have wanted to learn to do upgrades by myself for about six months now.

The last few weeks I have read the WordPress upgrade instructions at least twenty times. I even watched a few videos on how to upgrade your WordPress blog.

After doing my homework, I felt pretty comfortable about the prospect of upgrading sans Fantastico but scared.

It didn’t take more than five minutes to complete the upgrade.

It felt like hours.

I like the latest version which is supose to be faster and the dashboard is totally different. I am still trying to find my way around it, but I do like the changes.

I have been updating Vilay’s theme and plugins getting ready for the latest version. However, I will not update his blog manually because if it was not sucessful it may be the end of our marriage! ;)

Comments on this entry are closed.

  • expatraveler April 5, 2008, 2:10 am

    I should ask for your help as I unsuccessfully could not get the upgrade after I couldn’t use fantastico. Actually I tried about 4 times and then gave up since it just wasn’t working..

    Maybe I’ll get courage in a few weeks time once again. :)

  • Pumpkin April 5, 2008, 7:52 am

    Expatraveler, Let me know if you need my help. I like to figure out problems. It is one of my biggest strengths in a work environment.

    If you are updating from 2.3 to 2.5 it is much easier than if you are updating from a version before 2.3 to 2.5. There were a lot of changes in 2.3 that broke my blog even using fantastico because of plugin and theme compatibility. Now, I am really careful about checking that my theme and plugins are compatible with the latest version before I upgrade.

Next post:

Previous post:

Blog Widget by LinkWithin